Skip Navigation

Resources

 

Support Tools

 

Consumer Education

 

Business Education

 

Business Resources

 

Trouble viewing Internet Banking and Mobile Banking

Beginning June 25, 2017, Internet Banking and Mobile Banking users who use an older OS (operating system) version that doesn't not support TLS v1.2, will need to upgrade their mobile OS version to be able to connect to the mobile banking service. This is for both computers, tablets, and mobile devices.

 

To make sure you are able to use the Internet Banking and Mobile Banking services, both your computer and devices should be up to date.

 

Make sure your computers Internet Browser is the most up to date version. The browser must be compatible with TLS 1.2 (Transport Layer Security).

See the chart below:

browser_chart_tls_042117.JPG

 

Update your computers Internet Browser

 

Mobile Banking users must use devices on Android KitKat (Level 20) and above to be able to connect to the mobile banking service. IOS users must use a device operating on IOS 8 and above.

 

 

Customer Service

(816) 858-5400

24 Hour Telebanc

(816) 858-5000

© 2017 Platte Valley Bank of Missouri. All Rights Reserved.        Privacy Policy  ·  Sitemap  ·  Disclosures

   
 
Return to Mobile Site